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[KB215]Sentinel SuperPro key with Windows XP

Tags: Sentinel

14 years ago
By RM
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Applies to:

PcVue all versions with support for Windows XP.
This article contains obsolete references.


Summary:

In Windows XP, the Sentinel System Driver may not recognize the Sentinel SuperPro protection key (dongle) at startup. This article describes two work-arounds.


Solution:

Cause

When PcVue is started automatically (from the Windows Startup folder), the Sentinel driver key may not be loaded soon enough to enable it to run. PcVue then requests the Sentinel key.

Source

The SafeNet web site: http://www.safenet-inc.com/. Rainbow Technologies, who developed the Sentinel security products, merged with the SafeNet Corporation in March 2004.

The Sentinel System Driver for the parallel port and USB protection keys may not recognize the Sentinel SuperPro key for a couple of minutes after boot-up or until the protection key is reinserted into the PC. The service may not load at all if the user logs on as a non-privileged user.

Note

Log on to Windows XP as a user with Administrator rights, otherwise the service may not load.

Solution 1

This solution is more efficient and secure for most users.

  1. From the Windows Control Panel, open Administrative Tools then open Computer Management.
  2. In the View menu, select the option Show Hidden Devices.

Computer_Manager_dialog_View_Show_Hidden_Devices

  1. Select Device Manager then open Non Plug and Play Drivers.

Computer_Management_dialog_Device_Manager

  1. Select the Sentinel driver then right-click on Properties.
  2. In the Sentinel Properties dialog, select the Driver tab. In the Start-up section, choose System type instead of Auto.

Sentinel_Properties_dialog

  1. Close the dialogs to apply the setting.

Solution 2

This solution is for advanced users. The workaround proposed by Rainbow/SafeNet is to use the Registry Editor to modify the START parameter of the service entry of the Sentinel SuperPro Driver from AUTO_START (value 2) to SYSTEM_START (value 1).

This change causes the Sentinel System Driver to be loaded as a device driver during boot up. To achieve this, both the Sentinel service (as well as SNTNLUSB where applicable) should be started as system services.

  1. Open the Register Editor (Start.Run.RegEdit) and navigate to the key HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\.
  2. Set the Start values for the parallel port and USB protection keys as shown below.

Sentinel_keys_in_RegEdit

Sentinel_super_pro

  1. Select File.Exit to close the Registry Editor dialog and apply the settings.

Created on: 26 Nov 2010 Last update: 04 Sep 2024